package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d{9}$)`)
var str = `123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789`
var substitution = "0\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}