import Foundation
let pattern = #"(^\d{9}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)