# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http[s]?:\\/{2}.+\\/def/http:\/\/google.com\/def/g;t' <<< "<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href=\"http://localhostABCDEF/def/ABC/XYZ\">Some Text</element>"