use strict;
my $str = '<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>';
my $regex = qr/http[s]?:\/{2}.+\/def/p;
my $subst = 'http://google.com/def';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";