// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http[s]?:\/{2}.+\/def").unwrap();
let string = "<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href=\"http://localhostABCDEF/def/ABC/XYZ\">Some Text</element>";
let substitution = "http://google.com/def";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}