re = /http[s]?:\/{2}.+\/def/
str = '<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>'
subst = 'http://google.com/def'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result