import Foundation
let pattern = #"http[s]?:\/{2}.+\/def"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"http://google.com/def"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)