package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http[s]?:\/{2}.+\/def`)
var str = `<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>`
var substitution = "http://google.com/def"
fmt.Println(re.ReplaceAllString(str, substitution))
}