using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http[s]?:\/{2}.+\/def";
string substitution = @"http://google.com/def";
string input = @"<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href=""http://localhostABCDEF/def/ABC/XYZ"">Some Text</element>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}