$re = '/http[s]?:\/{2}.+\/def/';
$str = '<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>';
$subst = "http://google.com/def";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;