const regex = /http[s]?:\/{2}.+\/def/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http[s]?:\\\/{2}.+\\\/def', 'g')
const str = `<xml>http://localhost:8080/def/abc/xyx</xml>
<element xlink:href="http://localhostABCDEF/def/ABC/XYZ">Some Text</element>`;
const subst = `http://google.com/def`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);