# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=^sudo:x:\d+:.*$)(.*):/\1<mychar>/gm;t' <<< "sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz"