#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?=^sudo:x:\d+:.*$)(.*):"
Local $sString = "sudo:x:27:foo,bar,baz" & @CRLF & _
"nosudo:x:27:foo,bar,baz"
Local $sSubst = "\1<mychar>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)