using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^sudo:x:\d+:.*$)(.*):";
string substitution = @"\1<mychar>";
string input = @"sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}