$re = '/(?=^sudo:x:\d+:.*$)(.*):/m';
$str = 'sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz';
$subst = "\1<mychar>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;