const regex = /(?=^sudo:x:\d+:.*$)(.*):/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^sudo:x:\\d+:.*$)(.*):', 'gm')
const str = `sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz`;
const subst = `\1<mychar>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);