import Foundation
let pattern = #"(?=^sudo:x:\d+:.*$)(.*):"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1<mychar>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)