use strict;
my $str = 'sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz';
my $regex = qr/(?=^sudo:x:\d+:.*$)(.*):/mp;
my $subst = '\\1<mychar>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";