import re
regex = re.compile(r"(?=^sudo:x:\d+:.*$)(.*):", flags=re.MULTILINE)
test_str = ("sudo:x:27:foo,bar,baz\n"
"nosudo:x:27:foo,bar,baz")
subst = "\\1<mychar>"
result = regex.sub(subst, test_str)
if result:
print(result)