# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(rich:panel[^>]*)\blabel(\s*=)/\1header\2/gm;t' <<< " <rich:panel type=\"a\" label=\"b\">"