use strict;
my $str = ' <rich:panel type="a" label="b">';
my $regex = qr/(rich:panel[^>]*)\blabel(\s*=)/mp;
my $subst = '\\1header\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";