using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(rich:panel[^>]*)\blabel(\s*=)";
string substitution = @"\1header\2";
string input = @" <rich:panel type=""a"" label=""b"">";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}