// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(rich:panel[^>]*)\blabel(\s*=)").unwrap();
let string = " <rich:panel type=\"a\" label=\"b\">";
let substitution = "\\1header\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}