re = /(rich:panel[^>]*)\blabel(\s*=)/m
str = ' <rich:panel type="a" label="b">'
subst = '\\1header\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result