package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(rich:panel[^>]*)\blabel(\s*=)`)
var str = ` <rich:panel type="a" label="b">`
var substitution = "\1header\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}