$re = '/(rich:panel[^>]*)\blabel(\s*=)/m';
$str = ' <rich:panel type="a" label="b">';
$subst = "\1header\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;