const regex = new RegExp('(rich:panel[^>]*)\\blabel(\\s*=)', 'gm')
const str = ` <rich:panel type="a" label="b">`;
const subst = `\1header\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);