#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d+(\-[XIV]+)*(\-\d+)*"
Local $sString = "1 2 3 the" & @CRLF & _
"the quick 2354" & @CRLF & _
"feb 1 " & @CRLF & _
"feb 0" & @CRLF & _
"feb -10" & @CRLF & _
"feb23" & @CRLF & _
"88" & @CRLF & _
"feb 3" & @CRLF & _
"february 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")