import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(\\-[XIV]+)*(\\-\\d+)*";
final String string = "1 2 3 the\n"
+ "the quick 2354\n"
+ "feb 1 \n"
+ "feb 0\n"
+ "feb -10\n"
+ "feb23\n"
+ "88\n"
+ "feb 3\n"
+ "february 10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}