// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d+(\-[XIV]+)*(\-\d+)*").unwrap();
let string = "1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}