package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(\-[XIV]+)*(\-\d+)*`)
var str = `1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}