using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(\-[XIV]+)*(\-\d+)*";
string input = @"1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}