re = /\d+(\-[XIV]+)*(\-\d+)*/
str = '1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10'
# Print the match result
str.match(re) do |match|
puts match.to_s
end