const regex = /\d+(\-[XIV]+)*(\-\d+)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(\\-[XIV]+)*(\\-\\d+)*', '')
const str = `1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}