#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$"
Local $sString = "public $var;" & @CRLF & _
"public $int;" & @CRLF & _
"private $var2;" & @CRLF & _
"protected $protected_var;"
Local $sSubst = "'$2',"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)