re = /^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$/m
str = 'public $var;
public $int;
private $var2;
protected $protected_var;'
subst = '\'$2\','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result