$re = '/^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$/m';
$str = 'public $var;
public $int;
private $var2;
protected $protected_var;';
$subst = "'$2',";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;