using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$";
string substitution = @"'$2',";
string input = @"public $var;
public $int;
private $var2;
protected $protected_var;";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}