// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$").unwrap();
let string = "public $var;
public $int;
private $var2;
protected $protected_var;";
let substitution = "'$2',";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}