import Foundation
let pattern = #"^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
public $var;
public $int;
private $var2;
protected $protected_var;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'$2',"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)