import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(public|protected|private){1}\\s*\\$([a-zA-Z0-9_]+)\\s*;\\s*$";
final String string = "public $var;\n"
+ "public $int;\n"
+ "private $var2;\n"
+ "protected $protected_var;";
final String subst = "'$2',";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}