const regex = /^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(public|protected|private){1}\\s*\\$([a-zA-Z0-9_]+)\\s*;\\s*$', 'mg')
const str = `public \$var;
public \$int;
private \$var2;
protected \$protected_var;`;
const subst = `'$2',`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);