# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(public|protected|private){1}\s*\$([a-zA-Z0-9_]+)\s*;\s*$"
test_str = ("public $var;\n"
"public $int;\n"
"private $var2;\n"
"protected $protected_var;")
subst = "'$2',"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.