#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m):60([FM]):([CD])\d{6}"
Local $sString = ":60F:C180235P56987456" & @CRLF & _
":60M:C184535P56987456" & @CRLF & _
":60F:D182335P56987456" & @CRLF & _
":60M:D180278P56987456"
Local $sSubst = ":60$1:$2120412"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)