const regex = /:60([FM]):([CD])\d{6}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':60([FM]):([CD])\\d{6}', 'gm')
const str = `:60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456`;
const subst = `:60$1:$2120412`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);