import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":60([FM]):([CD])\\d{6}";
final String string = ":60F:C180235P56987456\n"
+ ":60M:C184535P56987456\n"
+ ":60F:D182335P56987456\n"
+ ":60M:D180278P56987456";
final String subst = ":60$1:$2120412";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}