re = /:60([FM]):([CD])\d{6}/m
str = ':60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456'
subst = ':60$1:$2120412'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result