import Foundation
let pattern = #":60([FM]):([CD])\d{6}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":60$1:$2120412"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)