# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":60([FM]):([CD])\d{6}"
test_str = (":60F:C180235P56987456\n"
":60M:C184535P56987456\n"
":60F:D182335P56987456\n"
":60M:D180278P56987456")
subst = ":60$1:$2120412"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.