package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):60([FM]):([CD])\d{6}`)
var str = `:60F:C180235P56987456
:60M:C184535P56987456
:60F:D182335P56987456
:60M:D180278P56987456`
var substitution = ":60$1:$2120412"
fmt.Println(re.ReplaceAllString(str, substitution))
}